Hot water heater 2016 Fleetwood Excursion

  • 01/08/2019 6:32 PM
    Message # 6989878

    sudden loss of hot water throughout coach both gas and electric. Plugged into 50 amp shore power and initially had hot water after we stopped. Checked both gas and electric switches are on and wTer bypass is in correct position. Doesn’t seem like any power as red light by switches is not lighting up either.  Any ideas?   

  • 01/09/2019 10:40 AM
    Reply # 6990904 on 6989878
    Bill & Laura Johnson (Administrator)

    This may seem silly, but you have checked circuit breakers or fuses in the Battery Control Center?

  • 01/09/2019 9:02 PM
    Reply # 6992459 on 6989878

    Even sillier, but a very easy problem to solve: Check to see whether the sprayer in your utility bay is on. If it sprays, then shut both the hot and cold faucets. When these faucets are open a blind loop of cold water goes through your water heater and after a few moments of hot water, only cold water will come out in your sinks and shower. This has apparently been a problem for Fleetwood rigs years and is known by Fleetwood Service Technicians. 

    This fix worked for me; hope it works for you.

  • 01/12/2019 9:32 PM
    Reply # 6997667 on 6989878

    Try the  hot water tank  water mixer a valve on the back of the   tank. that was my problem on a  discovery

  • 03/19/2019 9:27 AM
    Reply # 7234145 on 6989878

    I had the same problem with my 2016 Discovery 37R.  Mine was a combination of issues.  First the control board was replaced.  Then, as noted above, I had my valves open on the shower in my sewer/water compartment.  Once I turned off the outside shower valves....poof...the hot water in the coach was fine.


©2012 all rights reserved, Fleetwood Motorhome Association.                                                                             Contact Us | Privacy Policy

Powered by Wild Apricot Membership Software